СвязьПроект

Российский системный интегратор
Текущее время: 13 авг 2022, 07:16

Часовой пояс: UTC




Начать новую тему Ответить на тему  [ Сообщений: 7 ] 
Автор Сообщение
 Заголовок сообщения: Не работает один порт на AP100B
СообщениеДобавлено: 30 янв 2013, 11:33 
Не в сети

Зарегистрирован: 24 май 2010, 10:11
Сообщения: 45
Здравствуйте, имеется в наличии данное железо. Установлено у клиента. Уже на второй железке подряд перестает работать превый порт 0/0 через какое то время. В статусе пишет disconnectingю Что это? Брак addpac? Почему выгорают порты? Шлюз подключен через ИБП, питание не дергается, второй порт исправно работает. По питанию шлюз конечно же дергали.
Прикладываю конфиг, версию и состояние неисправного порта.

Цитата:
SHAR# sh ver
APOS(tm) Kernel version 8.41.085
Copyright (c) 1999-2008 AddPac Technology Co., Ltd.

SHAR uptime is 0 days 00:12:47
Timezone Moscow offset 4 hour
SHAR current time is Wed Jan 30 15:22:19 2053
System image file is "flash:/ap100b_g2_v8_41_085.bin"

AP100B_G2 System software Revision 8.41.085
Released at Wed Mar 10 17:30:35 2010
Program is 1998320 bytes, checksum is 0x1001822c

32BIT RISC Processor With 150MHz Clock
16 Mbytes System Memory.
512 Kbytes System Boot Flash Memory
4 Mbytes System Flash Memory

1 RS232 Serial Console Interface
2 Ethernet/IEEE 802.3 Interface (100BaseTX)
Board Rev 1, Hardware Type 1(S2, O0)

Maximum number of mbufs is 512, 319 mbuf is free.
System CPU utilize is 2 percent.
Heap Memory is 16384 kbytes, 15194 kbyes is used, free is 1190 kbytes.

SHAR#
SHAR# sh run
Building configuration...

Current configuration:
!
version 8.41.085
!
hostname SHAR
clock timezone Moscow 4
!
username root password 7 CXAe3VmPZTlB1bNn0HRNuQ== administrator
!
!
script ntpdate Moscow
resynchronize 0 10
server ip 10.12.32.150
!
interface Loopback0
ip address 127.0.0.1 255.0.0.0
!
interface FastEthernet0/0
ip address 10.12.32.137 255.255.255.0
ip nat outside
speed auto
no qos-control
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
ip nat inside
speed auto
no qos-control
!
ip route 0.0.0.0 0.0.0.0 10.12.32.1
!
access-list 100 permit ip 192.168.10.0 0.0.0.255 any
!
!
ip nat inside source list 100 interface FastEthernet0/0 overload
!
!
snmp name AP100B_G2
!
!
http server
!
!
!
!
!
!
! VoIP configuration.
!
!
! Voice service voip configuration.
!
voice service voip
fax protocol t38 redundancy 0
fax rate 9600
h323 call start fast
h323 call tunnel enable
busyout monitor gatekeeper
busyout monitor sip-server
no busyout monitor callagent
busyout monitor voip-interface
!
!
! Voice port configuration.
!
! FXS
voice-port 0/0
caller-id enable
!
!
! FXS
voice-port 0/1
caller-id enable
!
!
!
!
! Pots peer configuration.
!
dial-peer voice 0 pots
destination-pattern 2610936
port 0/0
!
dial-peer voice 1 pots
destination-pattern 2610937
port 0/1
!
!
!
! Voip peer configuration.
!
dial-peer voice 1000 voip
destination-pattern T
session target sip-server
session protocol sip
codec g711alaw
no vad
dtmf-relay rtp-2833
fax protocol t38 redundancy 0
fax rate 9600
!
!
!
!
!
!
! Gateway configuration.
!
gateway
h323-id voip.10.12.32.137
no ignore-msg-from-other-gk
!
!
! SIP UA configuration.
!
sip-ua
sip-password xxxxxxxxxxxx
sip-server 10.12.33.4
response progress without-sdp
register e164
!
!
! MGCP configuration.
!
mgcp
vad
!
!
! Tones
!
!
!
!
line console
!
line vty
!
!
sms
quota 30
!
end


SHAR# sh voice port all

Voice port slot(0)/port(0)
line type = FXS
status = Disconnecting
input gain = 0 db
output gain = 0 db
PSTN backup port enabled
ring frequency = 25 Hz
ring cadence = 1000 msec on, 2000 msec off
reorder tone duration = 30 sec
line lock tone duration = 30 sec
power down duration = 0 sec
polarity inverse = disabled
clear down delay = 0 sec
clear down tone detect = disabled
tie connection = none
description =
translate incoming called-number = -1
translate incoming calling-number = -1
comfort noise generation = enabled
dial tone generation = enabled
echo cancellation = enabled
announcement = enabled
low dtmf gain = -8
high dtmf gain = -5
caller ID = enabled
caller ID type = bellcore
caller ID NAME = enabled
DID Type = normal
busyout action = none
backup busyout action = none
current callnumber = -1
holded callnumber = -1


Вернуться к началу
 Профиль  
Ответить с цитатой  
 Заголовок сообщения: Re: Не работает один порт на AP100B
СообщениеДобавлено: 31 янв 2013, 15:50 
Не в сети

Зарегистрирован: 14 фев 2011, 10:57
Сообщения: 428
Прошивку менять не пробовали? Порт после перезагрузки показывает тоже самое: disconecting?

Прошивка:http://yadi.sk/d/NV-PpPdn2GMTb


Вернуться к началу
 Профиль  
Ответить с цитатой  
 Заголовок сообщения: Re: Не работает один порт на AP100B
СообщениеДобавлено: 01 фев 2013, 05:05 
Не в сети

Зарегистрирован: 24 май 2010, 10:11
Сообщения: 45
Перепрошил - не помогло.При перезагрузки по питанию тоже ничего не меняется. Изначально все же работало, потом в один прекрасный момент перестал. Мерял напряжение на порту показывает примерно 0-1В, хотя должен 48. Причем, это уже второй AP100, у которого отваливается порт, у первого он выдает напряжение, но при этом еще и какой то странный гудок, такой что не воспринимаются DTMF от аппарата. Причем иногда он начинает работать.


Вернуться к началу
 Профиль  
Ответить с цитатой  
 Заголовок сообщения: Re: Не работает один порт на AP100B
СообщениеДобавлено: 05 фев 2013, 12:42 
Не в сети

Зарегистрирован: 24 май 2010, 10:11
Сообщения: 45
genal писал(а):
Прошивку менять не пробовали? Порт после перезагрузки показывает тоже самое: disconecting?

Прошивка:http://yadi.sk/d/NV-PpPdn2GMTb


Лучше бы не прошивал. После перепрошивки на 086 версию, перестала работать исходящая связь на втором порту (на первом почему то работает). При отправке INVITE адпаком, ему возвращается запрос 407 на данные аутентификации, но адпак не отрабатывает (No Username or Password available), хотя должен выслать повторный INVITE с запрошенными данными. Конфиг тот же что и в первом сообщении. При откате на версию 085 тот же в точности конфиг полностью работоспособен. Дебаг прикладываю.

Цитата:
AP100B# [102.860] VM(0/1/0) vmOffHook
[102.920] VM(0/1/0) vmTmoOffHook
[102.920] VM(0/1/0) Rx OffHook
[102.920] VP(0/1/0) open channel
[102.920] VM(0/1/0) Tx OFFHOOK_IND
[102.920] VM(0/1/0) play Dial tone
[102.920] VP(0/1/0) Tx IBS signal 6/0
[102.920] VP(0/1/0) Tx IBS dir 0
2 <CEP 000100> : Call Received
3 <CEP 000100> : Call Initiated : calledNumber() crv(0) total(0)
4 <Call 2> : ****** Call Created status(InitiatedByFXS) ver(8.28:2006-02-06-00-00) time(94) ****
5 <CEP 000100> : Calling number(46360090)
6 <CEP 000100> : Call id(5e000000-479d-650a-8005-0002a4075342) callNum(2)
D(9) [104.540] VM(0/1/0) Tx DIGIT_IND '9'
[104.540] VM(0/1/0) play mute
[104.540] VP(0/1/0) Tx IBS signal 2/0
[104.540] VP(0/1/0) Tx IBS dir 0
7 <Call 2> : Digit(9) at InitiatedByFXS
8 <Call 2> : MatchedAll
D(9) D(9) D(9) D(9) D(9) D(9) D(9) [104.620] VP(0/1/0) GeneralEvent IBS gen end
D(9) D(9) D(9) D(2) [104.740] VM(0/1/0) Tx DIGIT_IND '2'
9 <Call 2> : Digit(2) at CalleeDeterminedWaitDigit
10 <Call 2> : MatchedAll
D(2) D(2) D(2) D(2) D(2) D(2) D(2) D(2) D(2) D(2) D(2) D(7) [104.950] VM(0/1/0) Tx DIGIT_IND '7'
11 <Call 2> : Digit(7) at CalleeDeterminedWaitDigit
12 <Call 2> : MatchedAll
D(7) D(7) D(7) D(7) D(7) D(7) D(7) D(7) D(7) D(7) D(2) [105.160] VM(0/1/0) Tx DIGIT_IND '2'
13 <Call 2> : Digit(2) at CalleeDeterminedWaitDigit
14 <Call 2> : MatchedAll
D(2) D(2) D(2) D(2) D(2) D(2) D(2) D(2) D(2) D(2) D(9) [105.370] VM(0/1/0) Tx DIGIT_IND '9'
15 <Call 2> : Digit(9) at CalleeDeterminedWaitDigit
16 <Call 2> : MatchedAll
D(9) D(9) D(9) D(9) D(9) D(9) D(9) D(9) D(9) D(9) D(7) [105.570] VM(0/1/0) Tx DIGIT_IND '7'
17 <Call 2> : Digit(7) at CalleeDeterminedWaitDigit
18 <Call 2> : MatchedAll
D(7) D(7) D(7) D(7) D(7) D(7) D(7) D(7) D(7) D(7) D(7) D(0) [105.790] VM(0/1/0) Tx DIGIT_IND '0'
19 <Call 2> : Digit(0) at CalleeDeterminedWaitDigit
20 <Call 2> : MatchedAll
D(0) D(0) D(0) D(0) D(0) D(0) D(0) D(0) D(0) D(0) D(1) [106.010] VM(0/1/0) Tx DIGIT_IND '1'
21 <Call 2> : Digit(1) at CalleeDeterminedWaitDigit
22 <Call 2> : MatchedAll
D(1) D(1) D(1) D(1) D(1) D(1) D(1) D(1) D(1) D(11) [106.210] VM(0/1/0) Tx DIGIT_IND '#'
23 <Call 2> : Digit(#) at CalleeDeterminedWaitDigit
24 <Call 2> : MatchAllProcess After Sorted
<0> id(1000) dest(T) prefer(0) selected(1)
25 <Call 2> : Initiate callee with dial-peer(T) status(CalleeDeterminedAll) id(5e000000-479d-650a-8005-0002a4075342)
26 <NetEP 2> : InitiateOutCall: calledNum(92729701) callingNum(46360090) target(sip-server)
27 <NetEP 2> : DoCall: calledAddr(sip:92729701@10.12.33.4:5060) callingAddr(46360090)
[106.210] VM(0/1/0) set T38 enable by CCC
[106.210] VM(0/1/0) set T38 mode STD
[106.210] VM(0/1/0) Fax rate 9600
D(11) 28 <SIP 0> : No authentication information available
29 <SIP 2> : Send INVITE Request
D(11) [106.235] RTA(0/1/0) Rx RS_LISTEN_REQ callId=2 ssId=1 G711U
peer=0.0.0.0 mp=23006/23007 hp=0/0
[106.235] VM(0/1/0) codec replace later to G711U
D(11) D(11) D(11) D(11) 30 <SIP 2> : Receive 100 Trying
31 <SIP 2> : Transaction (2 INVITE) proceeding
D(11) 32 <SIP 2> : Receive 407 Proxy Authentication Required
33 <SIP 2> : Transaction (2 INVITE) completed
D(11) 34 <SIP 2> : Send ACK Request
D(11) 35 <SIP 2> : No Username or Password available
36 <SIP 2> : ReleaseWithNothing
[106.300] RTA(0/1/0) Rx RS_CLOSE_REQ callId=2 ssId=1 dir=reve
[106.300] RTA(0/1/0) close Media socket
[106.300] RTA(0/1/0) close RTCP socket
37 <Call 2> : Terminated from(fffffffe) this(Remote:SecurityDenial) before(NULL) forced(0) time(97)
38 <CEP 000100> : DisconnectCall at Busy
39 <CEP 000100> : StopSignal
[106.300] RTA(0/1/0) Rx AP_SVC_REQ nSvcElem=1 rawDataLen=0
DTMF_STOP
[106.300] VM(0/1/0) play mute
[106.300] VP(0/1/0) Tx IBS signal 2/0
[106.300] VP(0/1/0) Tx IBS dir 0
40 <CEP 000100> : Disconnect (0)
[106.300] RTA(0/1/0) Rx CC_DISCONN_REQ CZ=0, peerId(0/0/0)
[106.300] VM(0/1/0) play Reorder tone
[106.300] VP(0/1/0) Tx IBS signal 6/3
[106.300] VP(0/1/0) Tx IBS dir 0
41 <NetEP 2> : Call TO <sip:92729701@10.12.33.4> terminated reason(Remote:SecurityDenial)
D(11) [106.320] VM(0/1/0) codec same G711U
[107.890] VM(0/1/0) vmOnHook
[107.940] VM(0/1/0) vmTmoOnHook
[107.990] VM(0/1/0) vmTmoOnHook
[108.040] VM(0/1/0) vmTmoOnHook
[108.090] VM(0/1/0) vmTmoOnHook
[108.140] VM(0/1/0) vmTmoOnHook
[108.190] VM(0/1/0) vmTmoOnHook
[108.240] VM(0/1/0) vmTmoOnHook
[108.290] VM(0/1/0) vmTmoOnHook
[108.340] VM(0/1/0) vmTmoOnHook
[108.390] VM(0/1/0) vmTmoOnHook
[108.440] VM(0/1/0) vmTmoOnHook
[108.490] VM(0/1/0) vmTmoOnHook
[108.540] VM(0/1/0) vmTmoOnHook
[108.590] VM(0/1/0) vmTmoOnHook
[108.590] VM(0/1/0) Rx OnHook
[108.590] VM(0/1/0) vopp idle
[108.590] VP(0/1/0) close channel
[108.590] VM(0/1/0) Tx DISCONN_CNF
42 <CEP 000100> : Disconnected(16) at Disconnecting


Вернуться к началу
 Профиль  
Ответить с цитатой  
 Заголовок сообщения: Re: Не работает один порт на AP100B
СообщениеДобавлено: 07 фев 2013, 15:21 
Не в сети

Зарегистрирован: 14 фев 2011, 10:57
Сообщения: 428
А если в sip-ua написать user-reg.
И я не понял, так второй порт работает или нет?


Вернуться к началу
 Профиль  
Ответить с цитатой  
 Заголовок сообщения: Re: Не работает один порт на AP100B
СообщениеДобавлено: 08 фев 2013, 04:45 
Не в сети

Зарегистрирован: 24 май 2010, 10:11
Сообщения: 45
genal писал(а):
А если в sip-ua написать user-reg.


Если делать через user-reg и прописывать регистрационные данные user-name и user-password в dial-plan, то все работает нормально.

genal писал(а):
И я не понял, так второй порт работает или нет?

Я уже описывал ситуацию.
Цитата:
Мерял напряжение на порту показывает примерно 0-1В, хотя должен 48. Причем, это уже второй AP100, у которого отваливается порт, у первого он выдает напряжение, но при этом еще и какой то странный гудок, такой что не воспринимаются DTMF от аппарата. Причем иногда он начинает работать.

Опишу сначала и по порядку снова: стоял один шлюз AP100B - перестал работать DTMF и при разговоре сильный фон на порту 0/0. Этот шлюз поменяли на такой же с той же прошивкой 085, через некоторое время гудок на порту 0/0 уже второго шлюза пропал в принципе . Питания он не выдает никакого - меряли тестером. Замеряли напряжения с телефона абонента (вариант что он выдавал какое-то напряжение в порт и спалил его) - все нормально 0В. Одновременно с этим проводил эксперименты на первом шлюзе - периодически неисправный порт начинал работать.
По вашему совету перепрошил на 086 версию и первый, и второй шлюз. После этого поступила жалоба от абонента, что невозможно позвонить с порта 0/1 (0/0 уже перестал работать). По дебагу увидел, что перестали ходит инвайты с регистрационными данными при стандартном конфиге с порта 0/1, а через user-reg работает. Откатил на втором шлюзе прошивку назад - порт 0/1 заработал, 0/0 так и не работает. При откате прошивки на втором шлюзе вообще праздник - теперь грузится только Booter, какая то версия APOS(tm) Boot Kernel Version 5.2.3, коннектится только через сервисный LAN1. При попытке сделать put <файл прошивки> разных версий через ftp пишет
Цитата:
C:\Users\s.orlov>ftp 192.168.10.1
Связь с 192.168.10.1.
220 Booter FTP server (Version 5.2.3) ready.
Пользователь (192.168.10.1:(none)): root
331 Password required for root.
Пароль:
230 User root logged in.
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for '/bin/ls -la -- .' (61 bytes).
drw-r--r-- 2 root other 108 Jan 1 00:00 tmp/
226 Transfer complete.
ftp: 62 байт получено за 0,00 (сек) со скоростью 62000,00 (КБ/сек).
ftp> lis
Недопустимая команда.
ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for '/bin/ls -- .' (5 bytes).
tmp/
226 Transfer complete.
ftp: 6 байт получено за 0,00 (сек) со скоростью 6000,00 (КБ/сек).
ftp> put D:\ap100b_g2_v8_41_085.bin
200 PORT command successful.
150 Opening ASCII mode data connection for 'ap100b_g2_v8_41_085.bin'.
226-WARNING! 5583 bare linefeeds received in ASCII mode
File may not have transferred correctly.

226 Transfer complete.
ftp: 1998320 байт отправлено за 1,69 (сек) со скоростью 1179,65 (КБ/сек).
ftp>



Вернуться к началу
 Профиль  
Ответить с цитатой  
 Заголовок сообщения: Re: Не работает один порт на AP100B
СообщениеДобавлено: 19 фев 2013, 09:54 
Не в сети

Зарегистрирован: 24 май 2010, 10:11
Сообщения: 45
C прошивкой разобрался - при коннекте по фтп нужно еще вручную сделать bunary режим.
Цитата:
При откате прошивки на втором шлюзе вообще праздник - теперь грузится только Booter, какая то версия APOS(tm) Boot Kernel Version 5.2.3, коннектится только через сервисный LAN1. При попытке сделать put <файл прошивки> разных версий через ftp пишет
Цитата:
C:\Users\s.orlov>ftp 192.168.10.1
Связь с 192.168.10.1.
220 Booter FTP server (Version 5.2.3) ready.
Пользователь (192.168.10.1:(none)): root
331 Password required for root.
Пароль:
230 User root logged in.
ftp> dir
200 PORT command successful.
150 Opening ASCII mode data connection for '/bin/ls -la -- .' (61 bytes).
drw-r--r-- 2 root other 108 Jan 1 00:00 tmp/
226 Transfer complete.
ftp: 62 байт получено за 0,00 (сек) со скоростью 62000,00 (КБ/сек).
ftp> lis
Недопустимая команда.
ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for '/bin/ls -- .' (5 bytes).
tmp/
226 Transfer complete.
ftp: 6 байт получено за 0,00 (сек) со скоростью 6000,00 (КБ/сек).
ftp> put D:\ap100b_g2_v8_41_085.bin
200 PORT command successful.
150 Opening ASCII mode data connection for 'ap100b_g2_v8_41_085.bin'.
226-WARNING! 5583 bare linefeeds received in ASCII mode
File may not have transferred correctly.

226 Transfer complete.
ftp: 1998320 байт отправлено за 1,69 (сек) со скоростью 1179,65 (КБ/сек).
ftp>




Вернуться к началу
 Профиль  
Ответить с цитатой  
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 7 ] 

Часовой пояс: UTC


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
cron
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB