СвязьПроект

Российский системный интегратор
Текущее время: 04 дек 2020, 14:22

Часовой пояс: UTC




Начать новую тему Ответить на тему  [ Сообщений: 3 ] 
Автор Сообщение
СообщениеДобавлено: 05 ноя 2012, 06:28 
Не в сети

Зарегистрирован: 05 ноя 2012, 06:20
Сообщения: 2
Здравствуйте.
Прошу помощи с настройкой входящих звонков.
Задача транслировать входящий звонок с addpaс`a на астериск.
Перечитал множество статей и форумов, исходящие работают, а вот входящие настроить не получается.

Addpac 10.254.254.4
Asterisk 10.254.254.102
Конфигурация Addpac:
Цитата:
! APOS(tm) configuration saved from vty
! 2012/10/05 13:50:54
!
version 8.51.002
!
hostname GS1002
!
username root password router administrator
username guest password guest user
!
!
interface Loopback0
ip address 127.0.0.1 255.0.0.0
!
interface FastEthernet0/0
ip address 10.254.254.4 255.255.255.0
ip nat outside
speed auto
no qos-control
!
interface FastEthernet0/1
ip address 192.168.1.7 255.255.255.0
ip nat inside
speed auto
no qos-control
!
access-list 100 permit ip 10.254.254.0 0.0.0.255 any
!
!
ip nat inside source list 100 interface FastEthernet0/0 overload
!
!
!
ftp server
http server
!
logging command
logging event 4-warning
logging on
!
!
!
!
! VoIP configuration.
!
!
! Voice service voip configuration.
!
voice service voip
protocol sip
dtmf-relay out-of-band
fax protocol t38 redundancy 0
fax rate 9600
h323 call start fast
h323 call tunnel enable
no call-barring unconfigured-ip-address
no voip-inbound-call-barring enable
!
!
! Voice port configuration.
!
! GSM
voice-port 0/0
connection plar 881
caller-id enable
caller-id type etsi
caller-id name disable
!
!
! GSM
voice-port 0/1
connection plar 882
caller-id enable
caller-id type etsi
caller-id name disable
!
!
!
!
! service port group configuration.
!
!
!
! Pots peer configuration.
!
dial-peer voice 3048 pots
destination-pattern T
port 0/0
call-waiting
user-name gsm1
user-password gsm1pass
preference 2
!
dial-peer voice 3049 pots
destination-pattern T
port 0/1
call-waiting
user-name gsm2
user-password gsm2pass
preference 3
!
!
!
! Voip peer configuration.
!
dial-peer voice 10100 voip
destination-pattern T
session target ip 10.254.254.102
session protocol sip
voice-class codec 0
no vad
dtmf-relay info
!
!
!
!
!
gatekeeper
!
!
! Gateway configuration.
!
gateway
h323-id voip.10.254.254.4
no ignore-msg-from-other-gk
!
!
! SIP UA configuration.
!
sip-ua
user-register
sip-server 10.254.254.102
called-party-number to-field
register e164
!
!
! Tones
!
!
!
!
line console
!
line vty
!
gsm dev-restart-by-unreg 300
!
gsm 0/0
sms-language utf8
!
gsm 0/1
sms-language utf8
!


в астериске прописал в extensions.conf
Цитата:
[default]
include => dph
[dph]
exten => _0XXXXXXXXX,1,Dial(SIP/gsm1/${EXTEN},120)
exten => _0XXXXXXXXX,n,HangUp()
exten => 881,1,Dial(SIP/110,120)
exten => 881,n,HangUp()




Но не могу понять логики, куда все таки идет входящий звонок?


Вернуться к началу
 Профиль  
Ответить с цитатой  
 Заголовок сообщения: Re: Addpac GS-1002 и Asterisk, входящие звонки
СообщениеДобавлено: 05 ноя 2012, 07:04 
Не в сети

Зарегистрирован: 05 ноя 2012, 06:20
Сообщения: 2
Все, разобрался
Входящие поступают.


Вернуться к началу
 Профиль  
Ответить с цитатой  
СообщениеДобавлено: 01 фев 2016, 10:33 
Не в сети

Зарегистрирован: 08 май 2014, 08:08
Сообщения: 6
Добрый день! Обычно после слов "я разобрался" и "у меня всё получилось" люди пишут конкретику для остальных.


Вернуться к началу
 Профиль  
Ответить с цитатой  
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 3 ] 

Часовой пояс: UTC


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
cron
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB